Webex Bots: New bots have a short token expiration
Incident Report for Cisco Webex Teams
Resolved
Engineering has deployed the hotfix, and confirmed that new tokens being generated are working as expected.

For any bots that were previously affected, please regenerate a new token, and this new token will be regenerated with the proper expiration length.
For any new bots created as of this update, tokens will be generated automatically as expected and no action is required.
Bots that were created prior to December 20th at 0200 UTC continue to be unaffected and require no action.

Thank you for your patience, and our apologies for any inconvenience this issue caused.
Posted 3 months ago. Dec 22, 2018 - 00:11 UTC
Identified
Webex Engineering has identified an issue with the token expirations for bots that were created after December 20th at 0200 UTC. These tokens have a very short refresh value (approximately 6 hours) rather than an indefinite period of time.

Engineering is working to create a hotfix to address this issue. For bots that have a token that has expired, these can be refreshed, and will be extended for an additional few hours. Once the hotfix is deployed, we will provide an update, and then those bots' tokens can be refreshed one last time and have the extended token period that is expected.

Bots created prior to December 20th are unaffected.

We apologize for the inconvenience and appreciate your patience while we address this issue.
Posted 3 months ago. Dec 21, 2018 - 22:27 UTC
This incident affected: Developer API.